PlayTruckSims: Грузовые симуляторы, Дальнобойщики, Euro Truck Simulator 2, American Truck Simulator

Информация о пользователе

Привет, Гость! Войдите или зарегистрируйтесь.


Вы здесь » PlayTruckSims: Грузовые симуляторы, Дальнобойщики, Euro Truck Simulator 2, American Truck Simulator » ZModeler » ZModeler3: вопросы, ответы, пожелания, помощь в освоении (часть 3/3)


ZModeler3: вопросы, ответы, пожелания, помощь в освоении (часть 3/3)

Сообщений 901 страница 930 из 1000

901

а что это за мат? (в игре/в редакторе как выглядит) ?

0

902

Его используют для жипиэса или другова дашборда, обычный диф.люм, тока не дает засвета, подсветка более ровно работает.
зы: в длс игрушек он используется для жипиэса, возможно его спецом для допа сделали.

Отредактировано dmitry68 (2016-03-31 21:24:38)

0

903

залил обновление. суффиксы .lvcol и .linv в шейдерах уходят в User-defined options как LVCOL и LINV.

0

904

Кто нибудь объяснит, что происходит. Вот, мапинг в Максе.
http://s019.radikal.ru/i616/1604/6c/0d93faf15467.png
Видно что полосы идут ровно, по всей длине. А вот так это выглядит в игре
http://s017.radikal.ru/i412/1604/5c/75fb0d4dc776.png
Все сдвинуто, перемешано, кое что вообще вверх ногами. Раскладка, какова была в Максе, такова и в Занозе. Ничего не сдвинуто, все на своих местах. Сделал бы снимок модели и в Занозе, но назначаю на второй канал, вместо empty текстуры, свою тестовую, но на модели она не отображается, а просто бронзовой модель становится.

ЗЫ. Нашел способ глянуть - в Занозе тоже нормально лежит все. То есть каша начинается, после экспорта в игру. В чем причина?

Отредактировано oq37 (2016-04-01 17:23:01)

0

905

Могу предположить шо перекидывается на 3 канал при экспорте. И если у тя несколько матов в занозе тракпаинтов то на всех нуна менять на 2 канал.

ZModeler3
при импорте шейдер тракпаинт усехда закидывает деталь 2 на 3 канал и если не поменять перед экспортом то получится вот такая беда выше.

0

906

dmitry68 написал(а):

И если у тя несколько матов в занозе тракпаинтов то на всех нуна менять на 2 канал.

Один мат. А где менять, на второй канал?

0

907

В настройке мата на вкладке деталь2 есть выбор канала УВ там тож двоечка должна быть.

0

908

А, все, нашел. Все заработало. Как стало отображаться в Занозе, тогда заработало и в игре. ) Спасибо!!!

0

909

"/vehicle/truck/upgrade/ffenders/scania_rcab_edit/materials" path-container was specified for material with custom state variants: "difspec_24_Paint_c". Ensure this is intended configuration.
"/vehicle/truck/upgrade/ffenders/scania_rcab_edit/materials" path-container was specified for material with custom state variants: "color_Plastic_c". Ensure this is intended configuration.
"/vehicle/truck/upgrade/ffenders/scania_rcab_edit/materials" path-container was specified for material with custom state variants: "difspec_24_Plastic_c". Ensure this is intended configuration.
"/vehicle/truck/upgrade/ffenders/scania_rcab_edit/materials" path-container was specified for material with custom state variants: "color_Plastic_c". Ensure this is intended configuration.
Что сие означает и, главное, как устранить?

0

910

на примере первого сообщения

"/vehicle/truck/upgrade/ffenders/scania_rcab_edit/materials" path-container was specified for material with custom state variants: "difspec_24_Paint_c"

это означает, что материалу difspec_24_Paint_c назначена группа (путь экспорта/дислокации) /vehicle/truck/upgrade/ffenders/scania_rcab_edit/materials, при этом на материале есть поддержка различных состояний, что потребует от фильтра создать несколько .mat файлов по указанному пути. фильтр предупреждает, что данная конфигурация, как правило, ошибочная, поскольку пути обычно задаются для указания путей материалов, которые в игре уже есть (соответственно, оригинальные маты там тоже уже есть и их названия могут не совпасть с названиями матов-вариантов, которые составит программа на экспорте). В данном случае, как я вижу, это не игровая папка с матами, а твоя собственная, которая больше в игре, кроме как твоим модом, не используется. в таком случае, на это предупреждение можно забить.

Это сообщение-предупреждение, а не ошибка экспорта. фраза "Ensure this is intended configuration" означает "убедитесь, что это правильная конфигурация".

В исключительных случаях, когда мату действительно нужны различные состояния, при этом мат широко используется в игре и размещается в какой-то общей папке, можно напротив состояний в свойствах мата (там где список состояний в Material States) в колонке "Comment" (вторая колонка, не помню, как называется) можно прямо указать путь и имя файла для этого состояния на мате. Например, материал "травы" в префабах размещается в /material/grass и имеет несколько состояний - зеленая, сухая, и т.д. - вот этим состояниям в мате можно прямо прописать /material/grass/grass_green.mat и /material/grass/grass_dry.mat (ну примерно так они называны в игре, точно не помню), и тогда фильтр сделает экспорт материала и пропишет в PMD отсылы к вариантам мата по указанным путям и указанным именам файлов. один такой материал (сконфигурированный, с путями и именами) можно гнать на сотню своих префабов, чтоб не полодить несколько сотен идентичных материалов.

+1

911

ZModeler3 написал(а):

можно прямо указать путь и имя файла для этого состояния

Указываю, но заноза начинает формировать пути, которых я не указывал. Я не создавал путь в папку materials #1, как это сделала Заноза, я создавал путь в папку materials. Что не так делаю, почему Заноза создает другую папку?

0

912

сама она ничего с "#1" придумать не может. проверяй на других матах и в каздом мате на закладке Materials State тоже посмотри что вписано.

0

913

Олег, привет!
можно сделать, чтобы дополнительные цвета при перезагрузке программы
не слетали?http://s8.uploads.ru/t/UndSV.jpg

0

914

Не мог не поделится приколом. Делаю значит трак, дошел до анимы, впихиваю пока ток руль. Захожу в грулю и, шо я вижу. o.O  Сразу скажу, шо в моде нема никаких отсылок на деф. траки. Усё автономное. Но каким макаром мой трак влияет на ысовские я пока понять не могу. :crazyfun:

0

915

такая канитель происходит, когда материал сконфигурирован под одно количество UV каналов, а геометрия сохранена с другим. простое появление/удалени .altuv в материале приводит к такому эффекту. возможно пересечение матов в модели и твоем моде.

0

916

man3Dfan написал(а):

Олег, привет!
можно сделать, чтобы дополнительные цвета при перезагрузке программы
не слетали?

готово, обновляй.

+3

917

ZModeler3 написал(а):

готово, обновляй.

ооооооооо, круто!!
вот Спасибо!!

+1

918

ZModeler3 написал(а):

такая канитель происходит, когда материал сконфигурирован под одно количество UV каналов, а геометрия сохранена с другим. простое появление/удалени .altuv в материале приводит к такому эффекту. возможно пересечение матов в модели и твоем моде.

так канешна и было, но фишка в другом, шо мод выглядел нормально а ысовские траки полетели(кроме в900), + и другие модовские траки за ними. Но самое прикольное шо это было и на чистых профелях. :crazyfun:  И простым отключением мода не обошлось, пришлось выкорчовывать с каждова профиля любые упоминания. Походу какой то баг грули попался. o.O

up:Я выяснил причину этого прикола. У меня в модели интерьера на детали с шейдером тракпаинт было 4 канала УВ(как и на внешней модели), и это сказывалось и на 579 и 680. На этих моделей 3 канала.  А на w900 4 канала и он не реагировал. Я исправил в своей модели на 3 канала, и все пришло в норму. Но это реально прикольно. :) Отписался ысам, может выяснят почему юзерский автономный трак так прикольно ломает дефолт. o.O

Отредактировано dmitry68 (2016-04-11 14:05:20)

0

919

Олег, давно уже хочу спросить.
не получается выделить полигоны с помощью инструмента polyline
правой мышкой рисую, потом правый двойной клик и ничего не происходит.....
и в режиме вершин, тоже не получается.

0

920

man3Dfan написал(а):

Олег, давно уже хочу спросить.
не получается выделить полигоны с помощью инструмента polyline
правой мышкой рисую, потом правый двойной клик и ничего не происходит.....
и в режиме вершин, тоже не получается.


В режиме объекта выделится только полностью определённый объект. В режиме вершин, попавшие в выделенную область. При этом не забудь активировать режим вершин на самой модели, полигонах.

Отредактировано ШАМАН (2016-04-15 10:41:02)

0

921

man3Dfan написал(а):

вот видео, всё ,вроде, так и делаю

да, всё верно делаешь. а это всегда так было? попробуй сборку с сайта скачать и в ней применить инструмент? хотя я ничего криминального в настройках как у тебя не вижу, но все же, может какие-то настройки так влияют.

0

922

ZModeler3 написал(а):

да, всё верно делаешь. а это всегда так было? попробуй сборку с сайта скачать и в ней применить инструмент? хотя я ничего криминального в настройках как у тебя не вижу, но все же, может какие-то настройки так влияют.

когда создаю объект в занозе, тогда инструмент работает (скачал с сайта последнюю сборку, инструмент заработал)
а когда импортирую обж, инструмент не работает ни на поликах ни на вершинах ни на объектах.

0

923

man3Dfan написал(а):

когда создаю объект в занозе, тогда инструмент работает (скачал с сайта последнюю сборку, инструмент заработал)
а когда импортирую обж, инструмент не работает ни на поликах ни на вершинах ни на объектах.


Попробуй сбить оси к глобальным.

0

924

ШАМАН написал(а):

Попробуй сбить оси к глобальным.

попробовал, ничего не изменилось

0

925

ШАМАН написал(а):

Попробуй сбить оси к глобальным.


по идее все загруженное из obj идет с глобальными осями. проверил на загруженном объекте - так же всё сработало правильно.

теоретически, может не работать на очень больших (сотни тысяч "метров") объектах и очень маленьких (дестятые доли милиметров). либо, если объект очень далеко (километры) от начала координат. "метр" это 1.0 в единицах программы.

скинь мне пример obj на котором не работает после импорта.

0

926

ZModeler3 написал(а):

скинь мне пример obj на котором не работает после импорта.

в личку скинул

0

927

проверил на этом объекте - тоже работает.

+1

928

ZModeler3 написал(а):

проверил на этом объекте - тоже работает.

значит у меня глюк
сам я ни в жизнь не разберусь, ну да ладно, удобный инструмент, но привык уже без него
Спасибо!

0

929

После последнего сегодняшнего обновления, какие то баги с экспортом. А именно маты "truckpaint" экспортируются неправильно, пропадают текстуры, а вместо них идет замена empty! Олег, посмотри пожалуйста в чем дело. Да и ранее проблемы были с каналом, то есть экспортируешь со вторым каналом, а при импорте снова стоит третий. И каждый раз менять на нужный утомительно.

0

930

залил правку в качестве беты. у меня не получилось протестировать на ATS, что-то она не видит мой мод в папке mod... на ETS протестировал на iveco hiway, у нее в оригинале кабина с 3 UV каналами, но шейдер в мат-файле идет без .altuv (странно), поэтому в редактор приходит DETAIL2 (empty.dds) с настройкой на Manual UV#2. На экспорте (из-за наличия 3 UV каналов) в мат файл прилетает .altuv (по идее это правильная конфигурация) - в игре работает нормально, но под эту машину у меня нет тестового скина на третий канал. а стандартные скины работают нормально.

на траке под ATS сделал импорт/экспорт - вроде .mat получается нормальный. но в игре проверить не получилось. отпишитесь, если сможете проверить экспорт в ATS, правильно ли там всё работает. там, к примеру w900 шел с 4 каналами на материале truckpaint.

0


Вы здесь » PlayTruckSims: Грузовые симуляторы, Дальнобойщики, Euro Truck Simulator 2, American Truck Simulator » ZModeler » ZModeler3: вопросы, ответы, пожелания, помощь в освоении (часть 3/3)