PlayTruckSims: Грузовые симуляторы, Дальнобойщики, Euro Truck Simulator 2, American Truck Simulator

Информация о пользователе

Привет, Гость! Войдите или зарегистрируйтесь.


Вы здесь » PlayTruckSims: Грузовые симуляторы, Дальнобойщики, Euro Truck Simulator 2, American Truck Simulator » ZModeler » ZModeler3: вопросы, ответы, пожелания, помощь в освоении (часть 3/3)


ZModeler3: вопросы, ответы, пожелания, помощь в освоении (часть 3/3)

Сообщений 241 страница 270 из 1000

241

Всем привет, ребят, ткните носом в  FAQ как переконвентировать модель с более старого патча, под новый. Не судите строго, только начинаю, поиск не чего не дал конкретного, а вручную перелопатить весь Ваш форум, ну сами понимаете.

0

242

Saurys написал(а):

Всем привет, ребят, ткните носом в  FAQ как переконвентировать модель с более старого патча, под новый. Не судите строго, только начинаю, поиск не чего не дал конкретного, а вручную перелопатить весь Ваш форум, ну сами понимаете.


Надо просто поправить часть скриптов... файлы.sii

0

243

Saurys написал(а):

Всем привет, ребят, ткните носом в  FAQ как переконвентировать модель с более старого патча, под новый. Не судите строго, только начинаю, поиск не чего не дал конкретного, а вручную перелопатить весь Ваш форум, ну сами понимаете.

Проще всего просто запустить модель на новом патче и посмотреть лог, если будет вылет. Ну и поправить ошибку, если будет. Но скорее всего не будет. :crazyfun:

0

244

Возникла проблемка. Поработал в Занозе, сохранил сцену. Вроде всё нормально. Пробую её открыть через некоторое время и бац, она не открывается. Пишет мне: ZModeler is ready. Can not complete task: Your license denies this action. file:OpenSaveService.cpp line:888

Валидацию повторно проходил, но ничего не помогает.

0

245

classick написал(а):

Возникла проблемка. Поработал в Занозе, сохранил сцену. Вроде всё нормально. Пробую её открыть через некоторое время и бац, она не открывается. Пишет мне: ZModeler is ready. Can not complete task: Your license denies this action. file:OpenSaveService.cpp line:888

Валидацию повторно проходил, но ничего не помогает.

Попробуй скачать занозу еще раз и активировать её, мне помогло когда была такая проблема :flag:

0

246

playtruckcool
Спасибо, но не помогло...  :dontknow:

Такая ерунда после каждого сохранения сцены.

Всё, отбой. Разобрался.  :flag:

0

247

Подскажите как грамотно прописать адапт "lum" к мату с бампом, что бы при седующем экспорте он не слетал как показано на скринах (до экспорта и после импорта результат):

Свернутый текст

http://images.vfl.ru/ii/1416647190/eb1ed2c5/7019633_m.jpg http://images.vfl.ru/ii/1416647190/33a8be75/7019634_m.jpg

0

248

Stas556
чуть выше говорил вже. Диф. люм. шейдер не воспринимает бамп. В самой игре это прописано, в эффектах. Так шта, никак. :D

Отредактировано dmitry68 (2014-11-22 12:33:35)

0

249

да, наверное придется отдельно делать кнопочки с бампом и отдельно lum-маски с альфой на эти кнопки. бампа на lum шейдерах в effect/ets2/dif_lum не наблюдается.

0

250

Понял, спасибо за ответы! Тогда без бампа обойдемся с кнопочками.

0

251

Нужна помочь, подсказка, направление. Дело в следующем. сделал нормал мап, назначил мат с бампом, шейдер все дела(бамп пробывал и ргб и грб, текстура в формате АТИ2) зашел в игру смотрю о_О
http://sa.uploads.ru/t/TnGKH.jpg
вижу шо бамп начинает работать при "солнечном свете" в тени он ващще не проглядывается
http://sa.uploads.ru/t/qxMKZ.jpg
http://sa.uploads.ru/t/wl6s8.jpg
Решил посмотреть ночью, и О чудо, он таки есть:
http://sa.uploads.ru/t/RSLGH.jpg
Видеокарта невидия 780, короче завис в непонятках. решил проверить на радеоне 6450. Был безмерно удивлен, шо день шо ночь, результат один
http://sa.uploads.ru/t/Up8uD.jpg
http://sa.uploads.ru/t/tmfjF.jpg
Вот и ломаю терь голову как это побороть уже 2 дня. Нужна любая подсказка, куда копать. Я таки понимаю дрова невидии как то по хитрому отрабатывают шкурку АТИ2, или руки у мну настолько кривые, шо могу вот такой результат выдать :crazyfun:
доп инфа: дашборт тоже сделан бампом, но с ним проблем нема. o.O
зы: забыл. Отключение HDR не имеет результата.

Отредактировано dmitry68 (2014-11-26 13:48:54)

0

252

dmitry68
а bump текстуру вручную рисуете? Или же 3ds max используете ещё?

0

253

нормал мап в фотожопе сделана невидией тулс по карте высот.
зы: продолжаю ковырять. Откат дравов результата не дал. :angry:

Отредактировано dmitry68 (2014-11-27 12:05:29)

0

254

http://sa.uploads.ru/t/hERBA.jpg
Этот нормал-маппинг скоро сведёт меня с ума...
Что с этим делать? Если вообще смысл бороться с ним? Я ведь всего лишь вырезал окошко на модели..

0

255

Джо написал(а):

Этот нормал-маппинг скоро сведёт меня с ума...
Что с этим делать? Если вообще смысл бороться с ним? Я ведь всего лишь вырезал окошко на модели..

Создавай свою карту нормалей или не используй ее вообще. При втором варианте придется половину кабины перемоделивать.

0

256

Привет! парни посоветуйте как правильно привязывать детали в аниме! делаю ручки под руль там анима не только ручки но и на ручке есть, ручка анимирована отдельным пма от анимы на ней! анима на ручке имеит свой пма, анима на ручке лежит в иерархии ручки, в игре она работает, ручка нормально, но доп анима берет за основу центр осей! хотя в занозе пма работает так как надо!

0

257

ch_vitalik, попробуй сделать аниму которая вложена в иерархии с выключенной опцией "World tracks".

Джо в чем именно проблема - обведи или несколько скринов сделай - до/после. Normal\Calculate делать обязательно, когда меняется топология объекта, особенно если у него есть бамп.

0

258

Справа - то что было. Слева я перемоделил часть за окном (сделал вырез, так сказать). Проблема в бликах. Ракурс на обеих частях один, а блики абсолютно разные

0

259

Джо
скорей в всего что у тебя есть разрыв между вершинами и при пересчете вершин у тебя выходит как бы 2  разные отражения на одной детали я так понимаю?

0

260

ddewer написал(а):

Джо
скорей в всего что у тебя есть разрыв между вершинами и при пересчете вершин у тебя выходит как бы 2  разные отражения на одной детали я так понимаю?

Да не, такая текстура у SCS. Просто даже если трак без изменений просчет нормалей приводит к такому результату

0

261

Джо, пофиксил, обновляйся.

Update: Небольшая ремарка, DANZ в каком-то смысле прав. Дело в том, что у SCS калькуляция нормалей несколько иная, если сделать калькуляцию в занозе, то нормали немного изменятся. но это становится особо важно при использовании bump/normal мэппинга, поскльку карты нормалей в модели были рассчитаны для исходных нормалей. соответственно, если там был какой-то дефект (ну предположим, что был именно дефект), карта нормалей под него высчитывается и потом на модели одно другое компенсирует. вот пример с окном на вольво:

http://sa.uploads.ru/t/eQGsW.jpg

я предполагаю, что в оригинальной модели в углу выштамповки была не совсем правильно выставлена нормаль, и для такой не совсем правильной нормали они вычислили карту нормалей. обратите внимание, в левом-нижнем углу выштамповки текстура нормалей начинает менять цвет - т.е. "заваливает" форму, гнет её. хотя в реале эта выштамповка ровная, как поднос с краями, и там нет изгиба, кроме как по краям. с такой картой нормалей и "дефектной" нормалью мы получаем в итоге нормальное, ровное освещение и блик ложится как на ровную поверхность внутри этой выштамповки (на оригинальной модели и в игре). Но стоит сделать калькуляцию в ZM и получить (по моему мнению) правильные нормали, текстура нормалей перестает соответствовать модели, и мы начинаем видеть завал или изгиб там, где его быть не должно (правая часть моего скрина). так-что тут двоякий момент - калькуляцию делать надо, чтоб у измененной модели bump-нормали обновились, но при этом обновляются и нормали, переставая соответствовать текстуре. вот и получем упомянутые "у SCS текстуры нормалей кривые".

0

262

ZModeler3 написал(а):

ch_vitalik, попробуй сделать аниму которая вложена в иерархии с выключенной опцией "World tracks".

Олег она и отключена! ты про функцию в свойствах пма?

0

263

Версия 1.15 Кто нибудь уже разобрался с dif.lum.mult? Теперь все лайтбоксы, сделанные с его помощью, работают некорректно (чёрный цвет, срабатывают от поворотников). Что там SCS намудрили с этим материалом? Видимо из-за приборок?

0

264

axelrol
я думаю не сложно будет раз паковать новую базу и импортировать дефолтную модель и посмотреть что и как сделано!!!!

0

265

ddewer
в том то и дело, что SCS не делали никогда лайтбоксы таким способом. Это вообще метод Симона (50keda) когда делаются 2 копии детали, затем та что позади ставится на стандартную лайтмаску с простой белой текстурой, а спереди с основной текстурой делается dif.lum.mult. Это был единственный нормальный способ сделать подсветку "цветных" лайтбоксов вместе с фарами. Материалы после экспорта одни и те же, но эффект совершенно разный теперь. И не надо ставить свои восклицательные знаки - я не настолько глуп чтобы не распаковать и посмотреть прежде чем писать здесь.

Отредактировано axelrol (2014-12-13 16:49:14)

0

266

axelrol написал(а):

Теперь все лайтбоксы, сделанные с его помощью, работают некорректно (чёрный цвет, срабатывают от поворотников). Что там SCS намудрили с этим материалом?

У меня на Актросе "звезда"теперь светится постоянно (раньше на габаритах висела)  :unsure:

0

267

axelrol

на дашборде "eut2.dif.lum.decal.over" и "eut2.dif.lum" , но это в 1.14 - 1.15 увы пока нет...

Первый - активен постоянно + габариты (эффект молочного стекла + подсветка), второй - с габаритами (эффект подсвечивания). Поправьте если путаю...

Отредактировано ШАМАН (2014-12-13 18:00:21)

0

268

ШАМАН
у меня материал dif.lum.mult. Пробовал менять на обычный dif.lum - всё равно чёрное всё.

0

269

axelrol написал(а):

у меня материал dif.lum.mult. Пробовал менять на обычный dif.lum - всё равно чёрное всё.


dif.lum имеет поддержку цветов подсветки (шкалы/цифири), сами приборы на dif.spec... Вместо белой примени розовую текстурку...

Отредактировано ШАМАН (2014-12-13 18:35:24)

0

270

Докладаю. Пол дня убил на эти долбанные диф.люмы. И выяснил вот шо: шоб диф. люм работал на внешке нормально и включал подсветку вместе с габаритами он должен в обязательном порядке быть привязан к аксессуару под названием Decals. В противном случае будет гореть постоянно. Точно также с лайтбоксами. Переименовать в декалс и убрать эту подсветку лайтмаской. И будет гореть как положено. Патча пока не имею, но думаю шо это будет работать и на 1.15. Подтвердите хто нибудь.

Отредактировано dmitry68 (2014-12-14 01:21:30)

+1


Вы здесь » PlayTruckSims: Грузовые симуляторы, Дальнобойщики, Euro Truck Simulator 2, American Truck Simulator » ZModeler » ZModeler3: вопросы, ответы, пожелания, помощь в освоении (часть 3/3)