PlayTruckSims: Грузовые симуляторы, Дальнобойщики, Euro Truck Simulator 2, American Truck Simulator

Информация о пользователе

Привет, Гость! Войдите или зарегистрируйтесь.



Техпомощь.

Сообщений 301 страница 330 из 331

301

Виталий я понял о чём ты, вот скрин с кеши дефолта
https://a.radikal.ru/a08/2004/c6/89675598a944t.jpg
Оси на костях расположены так же как и у меня. Но модель щёток другая, там горизонтальные, а у меня вертикальные. И эта ось x показывает направление как будут стирать дворники. И мои вертикальные и стирают только той частью где расположена кость, по центру и  исключительно по горизонтали. Вроде не ошибся в выводах. Теперь бы понять как их развернуть и куда.

0

302

selonik, Сергей, проверь ещё раз, чтобы всё было так, как на этом скрине дефолтного Кеши:
http://images.vfl.ru/ii/1587822579/b9d07cf2/30326506_m.jpg
И на всякий случай, переименуй свои кости также, как в дефолте (не знаю, будет ли играть это роль или нет, но мало ли что).

+2

303

В общем сделал я наконец работоспособные дворники. 4 дня убил на то чтобы понять как это исправить. Спасибо всем за советы и они очень помогли. Так как показали мне где надо искать проблему.
Но теперь другая беда от ысы пришла. Добавил себе "симулятор открывающихся окон". Окошки открываются всё хорошо, до поры до времени, точнее до дождя. Открываем во время дождя и видим
https://b.radikal.ru/b30/2004/19/62307deb6fa2t.jpg
Дождь, снег остаётся на воздухе как будто там есть стекло. Оно и понятно, надо прописать в glass.dat маску. Прописал от кеши, само собой разумеется, маска не совпадает с моей моделью стекла. Решил поправить на текстуре, ага не тут то было. вместо графического файла типа png находим файл win_mask_l.mask и win_mask_r.mask. ЫСЫ вы что издеваетесь, (жаль что эти .... не заходят сюда и не читают сообщений) Расширение mask, что это как открыть, как исправить. Дебилы. Идиоты, столько времени забрали на то чтобы разбираться с этим моделированием, и каждый раз преподносят сюрпризы. Достало уже.
Ладно, эмоции надо утихомирить, ну и как всегда вопрос, как эту гадость, mask можно исправить. Открывал я файл хексом, думал может png файлу расширение поменяли как это сделали с архивом zip. Да нет там ничего похожего на png. По большему счёту нули. Может кто уже исправлял это и знает где рыть надо?

0

304

selonik написал(а):

как эту гадость, mask можно исправить. Открывал я файл хексом, думал может png файлу расширение поменяли как это сделали с архивом zip.

Допиши на конце ".tga". Потом открывай фотошопом.

+1

305

Так просто, почему я думал что png? Наверно считал что у него прозрачный слой. Тем не менее спасибо за подсказку. Пойду мучать дальше.

0

306

selonik написал(а):

В общем сделал я наконец работоспособные дворники.

В чём была загвозка? (чтобы и другие знали, и впредь такие ошибки не допускали)

0

307

Загвоздка как рас была в модели щёток и расположении на них костей. Виталя дал подсказку, про ось х как она должна быть расположена. Вот скрин на нём постарался объяснить.
https://c.radikal.ru/c27/2004/91/f91cd1541f72t.jpg
Если бы у меня были бы дворники расположены и работали бы как на дефолте уже бы давно проблема решилась. Но у меня другая конструкция и щётка двигается вертикально. Поэтому я "положил" кости на щётках чтобы ось x бегала по такому же направлению как и щётка. Если посмотреть на дефолте , то у них щётка из горизонтального положения принимает вертикальное и кость двигается по той же траектории что и щётка, по оси x. Поэтому у меня только полоса появлялась потому что кость по оси x двигалась горизонтально а щётка вертикально. И что не мало важно на правой щетке ось z должна смотреть наружу от лобового, иначе не будет стирать капли. Надеюсь понятно объяснил.

+5

308

Вопрос больше наверно к Вадиму (piva). Вот у меня приборка. При включении зажигания должна загораться подсветка приборной панели. Для этого нужно присвоить текстуре значение в материале dif. lum Тогда приборка подсвечивается постоянно, пока не выключишь зажигание. Так в чём вопрос. Приборка при подключении зажигания загорается светом текстуры. приборка белая, но мне надо чтобы загорелась зелёным. Можно поменять текстуру и она будет гореть зелёным, но тогда при выключении зажигания будет так же зелёная приборка. Можно ли как то сделать, чтобы приборка загоралась зелёным от одной текстуры, а при выключении зажигания подхватывала другую текстуру где она белая? Можно это сделать прописками не влазя в анимацию?

Отредактировано selonik (2020-04-28 19:01:05)

0

309

selonik написал(а):

Вопрос больше наверно к Вадиму (piva). Вот у меня приборка.

Это не ко мне, я же не моделю приборку, а беру ту которую намоделили :D
Приблизительно такая же проблема у Вольвы от Aradeth, у него тоже текстура приборки светится, потому что lum, а вот dashboard_color[], как ни крути, так ничего и не меняется. Видимо проблема в этом, только как это чинить в блендере или занозе, я, точно, не в курсе.
Можно еще поробовать backlight_with_lights: true или false, только это уже производная от проблемы dashboard_color.

+1

310

Да, совершенно верно, чтобы приборка засвечивалась при включении зажигания, нужно присвоить текстуре значение в материале dif. lum. А чтобы изменить цвет, нужно прописать  в dashboard_color_sui, в верхней строчке значения соответствующие цвету. Выбрать цвет можно с помощью программки которую делал Миша Stalker45, за что ему огромное спасибо! А также в папочке interior в файле standart.sii (название своего салона) прописать @include "dashboard_color.sui". Должно получиться примерно так. Если конечно такой вариант подходит)

http://forumfiles.ru/uploads/0000/2a/c0/16824/t966541.jpg  http://forumfiles.ru/uploads/0000/2a/c0/16824/t782867.jpg

Отредактировано Andrey_forum (2020-05-04 23:48:16)

+1

311

Никто с таким не сталкивался - везде, в галерее, в меню, везде есть номер передний, а в игре нету. Нажимаю Esc, выхожу в меню - номер есть, в игру -номера нету. Как такое вообще может быть?

0

312

oq37 написал(а):

Никто с таким не сталкивался - везде, в галерее, в меню, везде есть номер передний, а в игре нету. Нажимаю Esc, выхожу в меню - номер есть, в игру -номера нету. Как такое вообще может быть?


Это надо глянуть на сайте ворлд оф тракс там номер обновляется в игру.

0

313

Gaiver написал(а):

Это надо глянуть на сайте ворлд оф тракс там номер обновляется в игру.

Ой, где я только не глядел. Даже бампера реэкспортил. Чуть с ума не сошел. Все оказалось банально просто - была включена подвеска кабины, ну и каким то боком это затрагивает шасси, бампера и номера. Получалось, что бампер себе качался, номер сам по себе и номер под нагрузкой уходил за бампер. В меню трак стоит без нагрузки, потому номер на месте. А вот почему качаются бампер и номер, при том что думмис номера, в модели бампера(дефолт), это для меня загадка. Но хоть решил. ))

0

314

oq37 написал(а):

Ой, где я только не глядел


В луже глубокой проехал вот номер и отлетел)))

Отредактировано Gaiver (2020-05-04 16:54:35)

0

315

Andrey_forum написал(а):

с помощью программки которую делал Ваня Stalker45

А разве Ваню не Мишей зовут?..  :D

+4

316

Knox_xss
Я даже уже не помню, что там за программка была такая :D

+2

317

Программка называется SCS Color. Неужто забыл? Я ей постоянно пользуюсь для прописки базового цвета в раскрасках. Так что присоединяюсь к Andrey_forum со словами благодарности. Нужная программка.

+1

318

selonik
в новой тулзе кеда сделал возможность копировать цвет из конфигов и вставлять в блендер и наоборот. Конверт происходит "на лету".

0

319

vad&k написал(а):

в новой тулзе кеда сделал возможность копировать цвет из конфигов и вставлять в блендер и наоборот. Конверт происходит "на лету".

Это как?

0

320

selonik
справа у каждого цветового поля теперь появилась серая кнопка с беленьким кружочком. Если ее нажать, то выпадет менюшка из пяти пунктов. Первые три пункта прописывают настройки для разных луков и т.д., а последние два пункта как раз и отвечают за вставку/копирование цвета.
Только надо учитывать, что если цвет в том же мате прописан как, например 0.5, 0.5, 0.5, то блендер его поймет, а если 0.5 , 0.5 , 0.5 (пробел перед запятой) - то фигушки, выдасть ошибку, что не может прочитать цвет.

Отредактировано vad&k (2020-05-05 19:31:16)

+1

321

Knox_xss написал(а):

А разве Ваню не Мишей зовут?..

Да, действительно Саша, спасибо! Вышла ошибочка, не Ваня, а Миша. Прошу прощения.

+1

322

Кто нибудь может такое объяснить - Кенворт мой выведен отдельным, салон тоже выведен отдельно, но анимацицию использует дефолтную. Так вот в дефолте работает все нормально, а у меня ампер и вольтметр зашкаливают, а нагрузку на ось завышает вдвое. Анимация дефолтная, "animations.sui" тоже дефолт. Ладно -думаю - может где то, что то, как то с моделью связано, беру полностью дефолтный салон, только в прописке верхней строки меняю exclusive.kenworth.w900.interior, на exclusive.kenworth.w937.interior и сразу приборы начинают чудить. В папке с салоном ПМАшек нету, только ПМГ и ПМД салон. Хотя какое это имеет значение, если я беру полностью дефолтную прописку. Пытаюсь настраивать приборы в "animations.sui" - всё нормально настраивается, приборы реагируют на изменение значений. Но почему перестает работать дефолтная анима, да и то не вся, а только три прибора? Что за чудеса такие? Анима что, как то привязана к названию самого трака?

0

323

oq37 написал(а):

Что за чудеса такие? Анима что, как то привязана к названию самого трака?

Вряд ли (хотя иди их чехов знай - ныне они мастера выдавать сюрпризы  :D ).

oq37 написал(а):

Кенворт мой выведен отдельным, салон тоже выведен отдельно, но анимацию использует дефолтную.

Дефолтная анимация (с пропиской и всем прочим) выведена отдельно к твоему Кенворту? Или сидит на месте, а ты её просто используешь?
Попробуй вывести всё, что используешь дефолтное, к себе, отдельно.

0

324

Knox_xss написал(а):

Или сидит на месте, а ты её просто используешь?

Сидит на своем месте.

Knox_xss написал(а):

к себе, отдельно.

То есть переэкспортить аниму и ПМАшки перекидать?

0

325

oq37 написал(а):

То есть переэкспортить аниму и ПМАшки перекидать?

Не обязательно переэкспортить - просто скопировать всё к себе. Чтобы было автономным, не используя дефолт.

0

326

Knox_xss написал(а):

Чтобы было автономным, не используя дефолт.

Не помогло. Всё точно так же. Такое ощущение, что где то, что то скрытое есть, а что не знаю. Короче, нужно просто перенастраивать приборы, да и всё.  :canthearyou:

0

327

Вот у меня такое ощущение, что к европейскому тягачу, подключили американские приборы. А где задается общее давление в воздушной системе?

З.Ы. Так и есть. Вольтаж не был прописан в шасси, потому и шкалило. Давление было прописано,но шкалило, а после прописки вольтажа,перестало. Остальное теперь нужно в ходу проверить.

Отредактировано oq37 (2020-05-08 10:12:26)

0

328

Тут вот какое дело, Выложил я свой прицеп на форуме scs. В принципе всё нормально, но вот несколько сообщений на английском чего я не могу понять что исправить в модели. Первое
Hello Selonik, in the future, could an advanced coupling be installed? Thanks
Потом я ответил что не могу понять о чём речь мне написал другой юзер

He's talking about the airline & Electrical hook-ups. ( "Advanced Coupling" )
Also about the tires: SCS uses the newer 22.5 tires while back before the early 90's 24.5 were the norm.
To have the right tires you would have to model them. ( There are a few mod's that have had this done. <the Kenworth K700 for one>)
Ну про колёса понятно, а вот о каких Advanced Coupling они пишут и что это и где это на прицепе. Знающие английский подскажите, что это по нашему. Яндекс переводит так
Он говорит об авиалиниях и электрических соединениях. ( "Усовершенствованная Муфта" )
Какие авиалинии и что за муфта? Если речь идёт о кабелях то они есть  и работают. В общем растолкуйте мне пожалуйста о чём речь. Спасибо

0

329

Сергей, они говорят про усовершенсвованную сцепку(видать ты коллизию не поставил на шкворень) и говорят про шлаги и кабели соединяющие, тягач с прицепом.

+1

330

Олег это всё есть, и коллизия стоит и сцепка продвинутая
https://d.radikal.ru/d29/2005/f0/ad83cdc0ce28t.jpg
Вот поэтому я и не могу понять что они хотят, если это я всё ставил по дефолту

0