PlayTruckSims: Грузовые симуляторы, Дальнобойщики, Euro Truck Simulator 2, American Truck Simulator

Информация о пользователе

Привет, Гость! Войдите или зарегистрируйтесь.


Вы здесь » PlayTruckSims: Грузовые симуляторы, Дальнобойщики, Euro Truck Simulator 2, American Truck Simulator » ZModeler » ZModeler3: вопросы, ответы, пожелания, помощь в освоении (часть 4/4)


ZModeler3: вопросы, ответы, пожелания, помощь в освоении (часть 4/4)

Сообщений 271 страница 300 из 302

271

ZModeler3 написал(а):

кому не лень, проверьте, запускается и работает ли сборка под 64-бит:

http://www.zmodeler3.com/files/zmodeler3_x64.zip

пишут то ли не стартует, то ли DirectX не подхватывается, не пойму, мало данных. лицензия на нее ставится только через автоматическую валидацию.

окно об ограниченном сроке работы программы на старте - не обращайте внимания, это триальный StarForce на ней сейчас.

Олег, запустил у себя. Прога открылась без проблем, но регистрировать не стал.

0

272

Олег, вопрос нуба. А 64 бит нада по новому устанавливать или при обновлении сама поймет , шо ей нада.?

0

273

Парни, вопрос человека забывшего все - Создал иерархию, запихнул туда деталь, делаю экспорт, а оно получается пустой файл и в логе запись, что типа нету объекта. Что конкретно я забыл?

0

274

dmitry68 написал(а):

Олег, вопрос нуба. А 64 бит нада по новому устанавливать или при обновлении сама поймет , шо ей нада.?


версия 3.2.0 (64 бит) пока не доступна как обновление и ничего сама скачать/обновить не может. лицензия в ней ставится только автоматически - указать ей имя аккаунта и пароль платформы, она как и преждние версии должна сама скачать ключ и валидацию.

на компе могут работать разные версии с одним и тем же ключем, так-что сборку 64 бит можно смело пробовать в отдельной папке.

0

275

Подскажите, кто-нить, как в занозе на свежесозданном кубе фаску сделать? Что-то я не догоняю, как местным chamfer пользоваться...

0

276

Опять не могу активировать Занозу. Триал закончилась, а со своей лицензией опять такие же проблемы. Не пора ли их решить? И что дальше делать?

0

277

х64 версия не видит видеокарту ноутбука, как и х32...

0

278

ШАМАН написал(а):

х64 версия не видит видеокарту ноутбука, как и х32...

Виталий, ты имеешь в виду версия 3.2.0 не видит карту, а ранние версии видели? там по идее ничего не менялось, единственное с версией x64 прилагаются две библиотеки directX для 64бит, может они что-то по-другому делают.

0

279

ZModeler3 написал(а):

Виталий, ты имеешь в виду версия 3.2.0 не видит карту, а ранние версии видели? там по идее ничего не менялось, единственное с версией x64 прилагаются две библиотеки directX для 64бит, может они что-то по-другому делают.


Ни одна из версий не видит дискретную карту, приходится ручками прикручивать. Надеялся на х64, что там всё заработает...

0

280

Занозу запустил. Два дня конечно она заханырила, а процессе, но то такое. ) Сейчас интересует вопрос - почему при импорте убиваются лайтмаски и как это победить?

0

281

Jazzycat написал(а):

Подскажите, кто-нить, как в занозе на свежесозданном кубе фаску сделать? Что-то я не догоняю, как местным chamfer пользоваться...

на новом кубе грани порезаны. chamfer-у нужна непорезанная модель.

@oq37, что именно в оригинальных MAT файлах и какой материал создатётся? я там не менял в материале вроде ничего.

0

282

ZModeler3 написал(а):

я там не менял в материале вроде ничего.

Та в матфайлах все вроде нормально. Почему то раскладка мапинга второго канала слетает. приходится на лайтмаску заново фары перетекстуривать. На Кенворте попробовал - слетело, на 389м тоже самое.

0

283

ZModeler3 требуется твоя консультация. 1,29 бета вылетает такая ошибка:
<ERROR> [baked_model] Pieces using same material and parameter packets have different vertex buffer layout
<ERROR> [baked_model] Creation of 'chassis' baked model failed
<ERROR> [baked_model] Pieces using same material and parameter packets have different vertex buffer layout
<ERROR> [baked_model] Creation of 'cabin' baked model failed
Ответ Комата седня:
"by Komat » 30 Oct 2017 19:12
That model has two pieces which are using the same material (i.e. the same mat file) while having a different configuration of vertex data. For example different number of texture coordinates, different mapping of UV streams to texture coordinates, presence of tangent data."

И чот я не урузумел, 2+2 у мну не складываеться. Наскока знаю Заноза сливает детали с одним матом при экспорте, так было усехда. Можешь как то логически, на пальцах, обьяснить этот прикол, или они шота поменяли в пмг, в очередной раз.?
edit: кажись дошло до мну. Если я использую один мат для внешки и интерьера, то терь получаю такую хрень. Тож самое с моделями интерьера и анимы. Я прально понимаю? Это типа оптимизация такая?

Отредактировано dmitry68 (2017-10-30 23:32:42)

0

284

да, похоже на оптимизацию. у них материалы мэпятся на "vertex buffer layout" (на то, как именно сейчас пойдут данные о вершинках), соответсвенно либо разруливай на разные имена MAT файлов, либо готовь геометрию на внешке/салоне с одинаковыми настройками, чтоб на экспорте заноза подготовила идентичные "vertex buffer layout". учитывается количество каналов и наличие tangents в свойствах mesh -> vertices -> format. настройки достаточно выставить на одном объекте. если хоть один объект с материалом выставлен с tangents - всем объектам припишется tangents, то же с каналами - выставил два на одном объекте - для всех объектов этого материала выгрузятся два канала (даже если и не нужно или не собирался использовать два канала). особое внимание объектам, на которых несколько материалов назначены - там, к примеру, два канала нужны одному материалу, а второму они опционально (можно с ними, можно без), так второй мат сконфигурируется с двумя каналами автоматом из-за такого объекта (и все остальные объекты с этого материала выгрузятся с двумя каналами).

0

285

oq37 написал(а):

Почему то раскладка мапинга второго канала слетает.

Никуда она не слетает. Ее там нет изначально ) Игра использует только первый канал. Просто скопируй маппинг на второй канал. Экспорт мата 'как есть' с одним каналом в игре не работает.

+1

286

Jazzycat написал(а):

Ее там нет изначально )

Блин, как то и не подумал, что так может быть.)) Спасибо за подсказку!

0

287

Олег, привет!
в АТС появился новый параметр
\unit\hookup\vehicle_beacon.sii 
# Emergency (aka police, ambulance & firetrucks) beacons blinking
flare_blink : flare.vehicle.emergency.beacon_b.blink
брал думмисы прямо из дефолтных моделей, названия не менял.
после экспорта лампочки не горят.
сама модель игрой воспринимается, как полиция, это я проверил..

0

288

сделай импорт-экспорт оригинальной модели (можно сместить пару объектов) и посмотри, будет ли работать на этом може блинкер.

0

289

ZModeler3 написал(а):

сделай импорт-экспорт оригинальной модели (можно сместить пару объектов) и посмотри, будет ли работать на этом може блинкер.

тестил crown_victoria и ford_taurus
Не работает    flare_blink : flare.vehicle.emergency.beacon_b.blink 
всё остальное работает.

0

290

Всем привет, Олег префабы с последнего патча америки подгружаются не корректно. Интересует вот этот префаб prefab\fork_temp\us_split_rail_turnout_tmpl

0

291

а что именно с префабами не так? некорректно подгружается - это что имеется в виду?

в последнем обновлении новая версия префабов с навигацией по AI линиям, игра пытается сама конвертировать префабы старых версий, и, пишут, ошибки были. Я в тестовой сборке x64 сделал эти изменения, но не тестировал. если кто грузил тестовую сборку x64 и разбирается в префабах, грузаните снова и проверьте в игре на карте, работает ли. я так по логу импорта посмотрел, вроде всё правильно сделал, но мало ли, как в игре всё это работает. ссылка та же: http://www.zmodeler3.com/files/zmodeler3_x64.zip

0

292

ZModeler3 написал(а):

сделай импорт-экспорт оригинальной модели (можно сместить пару объектов) и посмотри, будет ли работать на этом може блинкер.

Олег, а стробоскопы сделаешь, чтобы работали?
и еще вопрос, а что даёт сборка 64 бит, новые возможности или работать шустрее будет?

0

293

man3Dfan написал(а):

ZModeler3 написал(а):

    сделай импорт-экспорт оригинальной модели (можно сместить пару объектов) и посмотри, будет ли работать на этом може блинкер.

Олег, а стробоскопы сделаешь, чтобы работали?
и еще вопрос, а что даёт сборка 64 бит, новые возможности или работать шустрее будет?

программа не прописывает что и как работать на модели должно - она только задает позицию спец-эффектов, остальное делает игра. все нововведения надо делать идентичными как в оригинальных моделях и сверять настройки .sii файлов. если что-то не работает, делать мод из оригинальной модели, путём ипорта и экспорта без изменений - если в таком моде пропадают какие-то функции в игре, пиши подробно, что именно пропадает, я посмотрю.

сборка 64-бит никаких плюшек не дает, только поднимает потолок используемой программой памяти.

0

294

ZModeler3 написал(а):

программа не прописывает что и как работать на модели должно - она только задает позицию спец-эффектов, остальное делает игра. все нововведения надо делать идентичными как в оригинальных моделях и сверять настройки .sii файлов. если что-то не работает, делать мод из оригинальной модели, путём ипорта и экспорта без изменений - если в таком моде пропадают какие-то функции в игре, пиши подробно, что именно пропадает, я посмотрю.

сборка 64-бит никаких плюшек не дает, только поднимает потолок используемой программой памяти.

так я всё подробно написал, пост 287
потом сделал импорт экспорт, пост 289
и сижу жду, попробовал экспорт на 64 сборке, результат такой же, не работают стробоскопы.

0

295

Всем привет. Хотелось бы узнать, что это ошибка. Появилась после обновления АТС под 1.29

Ошибка

<ERROR> [baked_model] Pieces using same material '/vehicle/truck/mack_rs/shadow.mat' and parameter packets have different vertex buffer layout {size: 44, .position:FLOAT_3@0, .normal:FLOAT_3@12, .color:UBYTE_4_NORM@24, .tex_coord_0:FLOAT_2@28, .tex_coord_1:FLOAT_2@36} vs {size: 36, .position:FLOAT_3@0, .normal:FLOAT_3@12, .color:UBYTE_4_NORM@24, .tex_coord_0:FLOAT_2@28}
<ERROR> [baked_model] Creation of 'chassis' baked model failed
<ERROR> [baked_model] Pieces using same material '/vehicle/truck/mack_rs/gray2.mat' and parameter packets have different vertex buffer layout {size: 36, .position:FLOAT_3@0, .normal:FLOAT_3@12, .color:UBYTE_4_NORM@24, .tex_coord_0:FLOAT_2@28} vs {size: 44, .position:FLOAT_3@0, .normal:FLOAT_3@12, .color:UBYTE_4_NORM@24, .tex_coord_0:FLOAT_2@28, .tex_coord_1:FLOAT_2@36}
<ERROR> [baked_model] Creation of 'cabin' baked model failed

Отредактировано playtruckcool (2017-11-13 16:59:04)

0

296

объекты используют один и тот же материал, но в первом случае у объекта 1 UV канал, во втором - 2 канала. На данный момент решение такое - резать геометрию на кускм по материалам и оьъектам с одним и тем же материалом выставить в свойствах одинаковое количество UV каналов.

0

297

Мужики. Доброго времени суток. Такой вопрос. Есть мод Scania RJL. Для ETS 2. Суть в том, что там есть решетка. Я открыл её в ЗМ как обычно. Там созданы States якобы Высока, низкая решетка. И так же можно выбирать Краска,Хром,Пластик. Я там немного подредактировал деталь и сделал эспорт. Мне показало вот такой лог. Теперь в игре эта рештка только в пластике и хроме, в краску не ставиться. Слетел МАТ. Но почему? Я маты даже не трогал. Вот скрины. http://s7.uploads.ru/t/ZbelC.jpg
http://s7.uploads.ru/t/qpsEl.jpg
http://sd.uploads.ru/t/t9sGA.jpg

0

298

ZModeler3 написал(а):

программа не прописывает что и как работать на модели должно - она только задает позицию спец-эффектов, остальное делает игра. все нововведения надо делать идентичными как в оригинальных моделях и сверять настройки .sii файлов. если что-то не работает, делать мод из оригинальной модели, путём ипорта и экспорта без изменений - если в таком моде пропадают какие-то функции в игре, пиши подробно, что именно пропадает, я посмотрю. .

Олег, привет!
ещё раз пишу подробно.
не работает  flare_blink : flare.vehicle.emergency.beacon_b.blink
\unit\hookup\vehicle_beacon.sii    остался по дефолту, тут я ничего не менял
сделал импорт -экспорт дефолтной модели, лампочки перестали работать.
у меня вся работа остановилась из-за этого.

0

299

Вопрос для общего развития - неужели неправильно выставленное количество uv-каналов (больше чем надо, 4 вместо 1, например, за меньшее чем надо речь не идет, и так понятно) может привести к графическим артефактам в игре, взрывающимся полигонам и т.д.?

0

300

ZModeler3 написал(а):

в последнем обновлении новая версия префабов с навигацией по AI линиям, игра пытается сама конвертировать префабы старых версий, и, пишут, ошибки были. Я в тестовой сборке x64 сделал эти изменения, но не тестировал. если кто грузил тестовую сборку x64 и разбирается в префабах, грузаните снова и проверьте в игре на карте, работает ли. я так по логу импорта посмотрел, вроде всё правильно сделал, но мало ли, как в игре всё это работает. ссылка та же: http://www.zmodeler3.com/files/zmodeler3_x64.zip

Привет Олег!
В новой версии ЕТС2 пишет, что префабы старой версии конвертируются в новую.  [prefab desc] Converting prefab descriptor '/prefab2/buksir/buksir.ppd' version 21 to current version (22) Это относится ко всем префабам с AI линиями и без AI линий.
Для ЕТС2 будет исправлять? Если будет,то только в тестовой сборке? Или ещё не смотрел?

0


Вы здесь » PlayTruckSims: Грузовые симуляторы, Дальнобойщики, Euro Truck Simulator 2, American Truck Simulator » ZModeler » ZModeler3: вопросы, ответы, пожелания, помощь в освоении (часть 4/4)