PlayTruckSims: Грузовые симуляторы, Дальнобойщики, Euro Truck Simulator 2, American Truck Simulator

Информация о пользователе

Привет, Гость! Войдите или зарегистрируйтесь.


Вы здесь » PlayTruckSims: Грузовые симуляторы, Дальнобойщики, Euro Truck Simulator 2, American Truck Simulator » ZModeler » ZModeler3: вопросы, ответы, пожелания, помощь в освоении (часть 4/4)


ZModeler3: вопросы, ответы, пожелания, помощь в освоении (часть 4/4)

Сообщений 391 страница 420 из 421

391

Pasha14 написал(а):

Скачал последнюю версию и активировал без проблем.

Скачал. Нифига не помогает. Все те же самые проблемы - истекшая, неудачно.

0

392

oq37 написал(а):

Нифига не помогает. Все те же самые проблемы - истекшая, неудачно.

По возможности, не надо лицензию останавливать на сроки более 1 дня (остановка вообще сделана для переноса на другой ID). потом сервер лицензий на истории со сроками и остатками лицензии может обсчитаться при генерации ключа.

в случае с симптомами как выше, рекомендую делать так:
- удалить ID в аккаунте (лицензия отвязывается от ID)
- добавить ID в аккаунт и активировать для него лицензию.
- вставить ключ в программу и посмотреть на количество дней - если оно верное, можно ставить лицензию окончательно*.

*. имеется в виду чистая установка ключа, когда в программе удалется CodeLib, программа обновляется, скачивая пустой CodeLib, потом ставится ключ и ставится валидация. последние два пункта делаются автоматически, если настроен онлайн доступ заново добавленной ID (часто забывают).

P.S. указанная выше проблема чаще всего появляется на длинных лицензиях в конце срока действия, рекомендую не тормозить лицензию в последние хотя бы дней 30. причины генерации неправильного ключа на отзывных лицензиях я так и не выявил, у меня на домашнем тестовом сервере Apache под виндой этого не разу воспроизвести не удалось, какая-то особая логика на сервере, где хостится сайт наверное. :(

+1

393

ZModeler3 написал(а):

рекомендую делать так:

Спасибо, так получилось. )

ZModeler3 написал(а):

в последние хотя бы дней 30

Не знал я про это.

ZModeler3 написал(а):

остановка вообще сделана для переноса на другой ID)

Плохо, что только для этого. Без остановок слишком дорого сейчас выходит. Для сборщиков, конвертщиков нормально, они постоянно работают в Занозе, а вот для работающих в Зд Максе, а Занозу использующих только для конверта, совсем другой расклад. Из полугодовой лицензии и месяца использования не набегает. Когда ничто не поджимает вроде и фиг с ним, а когда туговато, приходится раскорячиваться. )))

0

394

А что с Занозой? 3Д Макс теперь не принимает файлы в формате обж, выданные занозой. Те файлы, что сделаны в более ранних версиях импортирует на ура, а те что экспортил в обж Занозой, что вчера скачал, вот те ни в какую. Тупо Макс вылетает и все.

0

395

принудительно отключи на объектах второй UV канал перед экспортом.

экспорт с двумя UV каналами в OBJ не совсем легален, но поддреживается многими программами. 3dmax похоже не понимает такие файлы.

+1

396

ZModeler3 написал(а):

второй UV канал

Там не в канале было дело. Я создание mtl в Занозе не отключил, а в таком виде Макс не принимает. Без mtl импортнулся нормально. Не помню только, это и раньше с mtl такое было, или это в новой версии так? Оно ни на что не влияет, для меня, просто интересно.

0

397

oq37 написал(а):

Не помню только, это и раньше с mtl такое было, или это в новой версии так?

Раньше так было и сейчас ничего не изменилось.
У меня встречный вопрос к Олегу (ZModeler3). Что случилось с записью анимации? Я не могу правильно сохранить PMAшку руля. При сохранению ключей, руль скручивается в "бараний рог"!!! Масштаб стоит единица, так как раньше с масштабом проблемы были.
Другие PMAшки сохраняются без проблем

Свернутый текст

http://images.vfl.ru/ii/1525006554/2aa53cba/21552005_m.png

Проблема решена. Сделал другую анимацию.

Отредактировано Stas556 (2018-04-29 19:26:38)

+1

398

oq37 написал(а):

Там не в канале было дело. Я создание mtl в Занозе не отключил, а в таком виде Макс не принимает.

если вдруг будет время сравнить .mtl который создает макс и которые заноза выдает и руками поправить проблемный занозовский файл - дайте знать, что именно бахает макс на загрузке .mtl файлов от занозы...

0

399

Всем привет, возникла проблема, в уже созданный файл анимации интерьера я добавил рулевую колонку и сделал к ней анимацию, по иерархии засунул все куда надо, в занозе все отлично работало, так вот, экспортирую я модель анимации, т.е. PMD, в занозе никаких ошибок нет, а вот с импортом того же файла что-то не то, все варианты пропали, иерархия пустая, некоторых моделей нет, в общем смотрите сами.

Свернутый текст

http://ultrapic.net/i/no_category/6/3/14280.png
http://ultrapic.net/i/no_category/8/4/1427f.png

0

400

да, выглядит весьма странно. если добавляешь объект в иерархию, ему надо задать ID в свойствах. этот ID не должен повторяться с другими и должен быть не меньше, чем у родительского объекта.
как правило, новому объекту дают ID со значением, наибольшим в сцене, поскольку все остальные идут по порядку и свободных значений нет. смотри ID на самом нижнем объекте и на объекте наибольшей вложенности в ветвях иерархии.

но в сцелом импорт с пустой иерархией это ошибка, такого никогда не видел.

по отсутсвию состояний/вариантов - убедись, что не экспортировал с опцией "Default variants".

0

401

ZModeler3 написал(а):

сравнить .mtl который создает макс и которые заноза выдает

Короче, вычислил я таким способом, что крашит Макс.
Вот .mtl из Макса
# 3ds Max Wavefront OBJ Exporter v0.97b - (c)2007 guruware
# File Created: 02.01.2018 16:41:19

newmtl 02___Curtain
Ns 10.0000
Ni 1.5000
d 1.0000
Tr 0.0000
Tf 1.0000 1.0000 1.0000
illum 2
Ka 0.5882 0.5882 0.5882
Kd 0.5882 0.5882 0.5882
Ks 0.0000 0.0000 0.0000
Ke 0.0000 0.0000 0.0000
map_Ka D:\ETS2 mod\???? 1-130\base\vehicle\truck\upgrade\interior_decors\curtains\curtain_1.dlc_toys.dds
map_Kd D:\ETS2 mod\???? 1-130\base\vehicle\truck\upgrade\interior_decors\curtains\curtain_1.dlc_toys.dds
А это из Заноы
# Materials file generated by ZModeler 3.2.0 (Build 1181).

newmtl mg_tassel_1_mg_curtains
Ka 0.00 0.00 0.00
Kd 1.00 1.00 1.00
Ks 0.00 0.00 0.00
illum 2
Ns 30.000000
map_Ka -blendu on -blendv on mg_curtains.dds
map_Ks -blendu on -blendv on mg_curtains.dds

Зеленым выделил проблемной место. Если я беру вот это из максовского файла
map_Ka D:\ETS2 mod\???? 1-130\base\vehicle\truck\upgrade\interior_decors\curtains\curtain_1.dlc_toys.dds
map_Kd D:\ETS2 mod\???? 1-130\base\vehicle\truck\upgrade\interior_decors\curtains\curtain_1.dlc_toys.dds
и заменяю им то, что я выделил зеленым, файл импортируется. С руганью конечно, на отсутствие текстур, но запускается. Пробовал манипуляции с цифрами, менял значения, добавлял недостающие строки, ничего не помогало. Пока в занозовском файле, не трогая ничего более, не заменил эти две строки. Как то так. Надеюсь поможет. )

0

402

-blendu on -blendv on
эти опции добавляют сглаживание текстуры.
а попробуй опцию -s 2 2 2
т.е. вот так:

map_Ka -s 2 2 2 mg_curtains.dds
map_Ks -s 2 2 2 mg_curtains.dds

это масштабирование текстуры (по сути Tile U, Tile V), макс это поймет или тоже упадет? и как вариант, попробуй в максе вручную выставить на текстуре у материала Offset/Scale (по умолчанию они 0,0,0 и 1,1,1) отличные от дефолтных значений и экспортнуть файлик из макса - мне интересно, он эти настройки вообще понимает?

Edit:
и как вариант попробовать эти опции после имени файла воткнуть. например так:
map_Ka mg_curtains.dds -blendu on -blendv on -s 2 2 2

и если есть возможность посмотреть, какую вариацию воспринимает Blender.

Спецификация Obj/Mtl древняя, еще из 90 годов, обросла разными опциями с которыми, возможно, не все считаются.

И еще раз Edit:
погуглил малость на эту тему - у меня все же правильно сделано, по спецификации 95 года прям. скорее всего в плагине для макса сделали предположение, что всё, что после map_K* - это путь и имя файла и на попытке открыть файл "-blendu on -blendv on mg_curtains.dds" макс падает.
совсем убирать эти опции мне кажется не резон, могу добавить галку на экспорте, чтоб прописывались эти опции.

0

403

залил версию с галочкой для отключения этих опций.

+1

404

ZModeler3 написал(а):

да, выглядит весьма странно. если добавляешь объект в иерархию, ему надо задать ID в свойствах. этот ID не должен повторяться с другими и должен быть не меньше, чем у родительского объекта.
как правило, новому объекту дают ID со значением, наибольшим в сцене, поскольку все остальные идут по порядку и свободных значений нет. смотри ID на самом нижнем объекте и на объекте наибольшей вложенности в ветвях иерархии.

но в сцелом импорт с пустой иерархией это ошибка, такого никогда не видел.

по отсутсвию состояний/вариантов - убедись, что не экспортировал с опцией "Default variants".


Id стоят везде и правильно, опция Default variants не стоит, забыл упомянуть после импорта появляются какие-то новые объекты в иерархии без названия, они не имеют ни моделей, ни думисов.

Отредактировано Emmanuil (2018-05-03 08:40:58)

0

405

а без изменений сцену получается выгрузить (так чтоб потом обратно всё пришло с вариантами и с правильной иерархией) ?

0

406

ZModeler3 написал(а):

а без изменений сцену получается выгрузить (так чтоб потом обратно всё пришло с вариантами и с правильной иерархией) ?

Да, если ничего не трогать все нормально экспортируется и импортируется.

0

407

кинь мне ссылку на .z3d файл с измененной сценой перед экспортом.

0

408

ZModeler3 написал(а):

кинь мне ссылку на .z3d файл с измененной сценой перед экспортом.

В принципе вот, PMAшки нужны?

Свернутый текст

http://sharemods.com/b1q6kps57nyv/__________.rar.html

0

409

Joint25 (ID = 32) дочерний у St_col_ext (ID = 76). так нельзя делать.

0

410

Не знаю как часто обновлял ZM, но на сколько я понял 3.2.0 стала почти каждый день слетать. Приходится заного переустанавливать, вводить ключ, проводить валидацию (при чем все это никогда не получается сделать с первого раза). Ну и частенько всплывает вот такое при запуске сохранений:
https://b.radikal.ru/b16/1805/9e/ab61996b3de8.jpg

0

411

DANZ, а какая винда стоит? ошибка на скриншоте из защиты приложения, не могу ничего конкретного сказать по этому поводу, отправлю скрин в поддержку...

0

412

Вин 7 64-бит

0

413

Парни, кто с таким сталкивался - делаю импорт дефолтного фонаря, что на крыше, ничего не трогаю, делаю экспорт и перестает работать лайтмаска. При чем ничего не сбито. Замаплено, как обычно, на пятый квадрат.
http://ultrapic.net/i/no_category/2/thumb_145d7.jpg
Но в пятом квадрате ничего не работает. Перемещаю в первый квадрат, начинает работать через панель дополнительного света. При чем лайтмаска работает, хоть и белым светом. Возвращаю в пятый, там где по дефолту было - не работает лайтмаска. Что за фигня? ЧТо то в игре поменялось?
З.Ы. При чем когда мапишь на первый квадрат - белое свечение,включаемое через панель доп освещения. Второй - тоже самое,только желтое свечение. Третий,четвертый и пятый квадраты не работают вообще.

Отредактировано oq37 (2018-05-17 22:00:04)

0

414

проверь настройки каналов в материале и используемый мэппинг. возможно, геометрия была настроена на один канал в оригинале, а экспортировалась с двумя каналами. выстави вручную на MASK Manual UV#2, и если в геометрии такого канала нет, скопируй его с UV1. в новых моделях SCS активно используется подмена каналов отличная от дефолтной настройки шейдера (в ZM такой возможности нет).

0

415

ZModeler3 написал(а):

на MASK Manual UV#2,

Так лайтмаска на втором и стоит. На первый переставить?

0

416

Никак не поддается свет. Выходит и фары тоже нельзя замапить? Только верхние дополнительные и все. Все остальное никак не идет. Вот так сейчас выглядит настройка мата
http://ultrapic.net/i/no_category/4/9/8/8/8/3/thumb_145e8.jpg
Вот так замаплен первый канал.
http://ultrapic.net/i/no_category/8/7/3/0/thumb_145e9.jpg
Вот так второй.
http://ultrapic.net/i/no_category/2/thumb_145ea.jpg
Вроде все на своих местах, но лайтмаска не работает. Точнее работает, но только так, как я выше описал, а как надо никак не работает. И что делать?

0

417

тут только методом сужения круга поиска проблемы можно.. во-первых, загрзить модель обратно и убедиться, что мэппинг для маски сохранился, а также, что материал настроен правильно. второе - попробовать заменить содержимое файла материала оригинальными данными материала (пусть даже текстура не та будет) и посмотреть, что поменяется.

из последних изменений в программе только выгрузка количества каналов скорректирована была, т.е. программа стала выгружать больше данных, где это требовалось - уменьшить или порезать данные не должна была.

может, попробовать еще тестовые кубы сделать и посдывигать на них мэппинг встрону +1, +2, ... ,+6 квадраты и в игре посмотреть, как это работает (когда на поверхности кубя вся текстура маски видна, посмотреть, что именно на каком кубе будет включаться. вряд ли в самой игре что-то поменялось, так-что скорее всего надо сузить круг поиска и проблема найдется.

к слову, она может быть и в .tobj, может там какие-то незначительные изменения приключились - проверка с тестом на оригинальном мате/тобже может это выявить.

0

418

ZModeler3 написал(а):

тут только методом сужения круга поиска проблемы можно.

Короче, методом научного тыка? Занятная перспектива, однако. особенно если учесть, что я смутно себе представляю настройку матов именно в редакторе. %-)

0

419

настройки мата на скрине правильные. экспорт по идее не должен отличаться от того, что было ранее. почему не работает в игре - не знаю. я предложил сделать на траке несколько больших кубов и сдвинуть мэппинг им, чтоб на "полной текстуре на большом боксе" отчетливо видеть, как это всё работает. может, что-то прояснится. готового решения у меня нет, поскольку я не знаю, что именно перестало правильно работать в обсуждаемой проблеме.

0

420

Странно как то все это. Прямо перед этими всеми проблемами я делал импорт-экспорт Шварцмеллера, штору. И там лайтмаска работает прекрасно. Все как обычно. Что твориться здесь, пока не пойму нифига.

0


Вы здесь » PlayTruckSims: Грузовые симуляторы, Дальнобойщики, Euro Truck Simulator 2, American Truck Simulator » ZModeler » ZModeler3: вопросы, ответы, пожелания, помощь в освоении (часть 4/4)