PlayTruckSims: Грузовые симуляторы, Дальнобойщики, Euro Truck Simulator 2, American Truck Simulator

Информация о пользователе

Привет, Гость! Войдите или зарегистрируйтесь.


Вы здесь » PlayTruckSims: Грузовые симуляторы, Дальнобойщики, Euro Truck Simulator 2, American Truck Simulator » ZModeler » ZModeler3: вопросы, ответы, пожелания, помощь в освоении (часть 4/4)


ZModeler3: вопросы, ответы, пожелания, помощь в освоении (часть 4/4)

Сообщений 481 страница 510 из 529

481

если имеется в виду совсем другой eut2.diff_spec.что-то там, то никак.

варианты материалов допускают лишь разные текстуры с идентичными другими параметрами. Т.е. нельзя сделать вариант где материал будет с раскраской (truckpaint), и вариант где материал будет с хромом (eut2.diff_spec.add.env).

+1

482

Форумчане привет. Помогите пожалуйста с вопросом по программе ZModeler заточенной под ETS2. Я ZModeler только начал осваивать поэтому может вопрос будет глупый, но узнать у понимающих людей надо. Ситуация такая: я на префабах баз (на территориях мест разгрузки/загрузки) размещаю различные модели (паллеты, ящики, контейнеры и т.п.). Элементарные модели типа паллет меня научили ставить. Может кто-нибудь подсказать как на префаб добавлять модель прицепа например (как вариант /model2/vehicle/trailer/trailer_reefer_01_sc.pmd) . Естественно все модели я беру из распакованного архива "base.scs", и вообще речь веду только о тех файлах которые идут в игре и сделаны разработчиками SCS. Вообще мне нужно будет ставить на базах такие модели: припаркованная фура, полуприцеп, трактор, экскаватор, кара, бульдозер, и кран (различные варианты). Проблема вся в том, что тот алгоритм по которому я ставил паллеты на прецепе не работает. Т.е. там много пунктов которых нет у простых моделей типа паллет. Может сможет кто видео записать и в личку отправить если писать много. Буду признателен за любую помощь.

Всё, ребята. Кажется я просто не правильно понял. Вроде все модели ставятся по одному принципу, если её нужно просто поставить на префаб. Т.е. независимо от того что это будет простой паллет или фура на стоянке.

Отредактировано Holodok (2019-03-13 15:04:48)

+1

483

Holodok
Эти вещи добавляются при создании карты, в редакторе карт. В ЗМ создаются модели, для использования в редакторе, игре.

0

484

Кому требуется обновить моды под ETS2 1.35 (бета), можете воспользоваться сборкой из этой темы:
https://forum.zmodeler3.com/viewtopic.p … mp;t=11556

изменений никаких, только в pmg файлах использующих анимацию (и в самих .pma файлах анимации) добавилась связка для проверки на соответствие анимации и файла модели. файл анимации может применяться к любой модели, он никак не привязан - в новой версии добавили такую проверку. в идеале, надо просто сделать реэкспорт модели и всех её pma файлов. экстеръеры траков, профабы и статическая модель кабины скорее всего можно не обновлять (но игра может писать предупреждения простарый формат).

+4

485

ZModeler3 написал(а):

под ETS2 1.35 (бета)

Так она же не вышла еще. Или закрытая бета идет?

0

486

да, это под закрытую бету. там незначительное изменение формата, просто после выхода игра будет в логе писать "обновите свой экспортер для моделей" на каждый файл старой версии. ну или что-то похожее будет. изменения никак на производительности не скажутся, такие сообщения можно будет смело игнорировать, но можно и переэкспортировать модели.

+1

487

ZModeler3
Экспорт, конечно, хорошо. Но хотелось бы и импорт )) В бете импортируется только коллизия, модель где-то теряется по дороге ((

0

488

у себя проверял, загружается всё (что мне прислали).

скорее всего в папку закинул фильтр без замены существующего, и в программе получилось два фильтра. каким именно она пытается ипортировать - неизвестно.

0

489

ZModeler3
Олег, поставил твой фильтр на 64-х битную версию (с заменой существующего) и с её помощью попробовал переэкспортировать свою модель (кастомный тюнинг для стандартной VNL, с своей кабиной и шасси). В итоге в игре все детали стали перевёрнутыми задом наперёд и в логе ошибка на координаты (сейчас нет возможности скинуть её, тк восстановил модель из копии). Тоже самое на старой версии если проделать, то проблем нет, но лог будет ругаться на любой .pmg типа старый формат. Может что то с фильтром?

Отредактировано axelrol (2019-05-02 19:30:08)

0

490

В фильтре никаких изменений с осями не было. изменения с поворотом объектов были с год назад где-то и затрагивают ситуацию, когда модель открыта из .z3d и экспортируется в игру. в "новом" варианте, если не ошибаюсь, "рабочее" направление осей это -Z (в обратную сторону от синей оси), а в старом варианте было в +Z (по направлении синей оси). можно на дамми для разных flare посмотреть, как правильно. если сохранка старая, то скорее всего придется оси покрутить на объектах перед экспортом.

P.S. и скрин с ошибкой по осям лучше покажи, может там что-то важное упускаю.

0

491

ZModeler3 написал(а):

В фильтре никаких изменений с осями не было. изменения с поворотом объектов были с год назад где-то и затрагивают ситуацию, когда модель открыта из .z3d и экспортируется в игру

Вот как раз такая ситуация и у меня. Если делать экспорт существующей z3d модели, которая без проблем работала на 1.34 в новую версию 1.35, используя новую версию фильтра, то детали как раз переворачиваются. Если же делать экспорт в 1.34 (с старым фильтром), то проблем нет.

P.S. Хотя вроде решил проблему - оказывается заноза брала фильтр предыдущей версии, хотя я его скопировал в папку backup, он всё равно оттуда читался. Убрал папку подальше и теперь она считывает новый.

Отредактировано axelrol (2019-05-03 20:08:01)

0

492

плагины и фильтры загружаются из любых папок внутри папки программы, так-что бэкап либо вообще вынести куда-то далеко, либо переименовать расширение. программой загружаются файлы *.zm? (лобое имя и расширение, начинающееся с .zm).

по осям опять же - вряд ли в игре были такие изменения междо 1.34 и 1.35, скорее всего в программе стояла совсем старая версия фильтра, которая сама оси "выворачивает". просто она это делала неправильно (на коллизиях и в некоторых поворотах дамми это было видно). я убрал этот "ручной" разворот уже давно, про это был пост тут ранее.

0

493

ZModeler3
В общем, всё равно детали переворачиваются. Ссылки в логе на старые пмг отсутствуют - значит фильтр работает, но вот всё остальное переворачивается задом наперёд. Больше ошибок в логе нет. Уже даже и не знаю куда думать. У меня свой трак на базе стандартной VNL, который сделан отдельной кабиной и своим шасси (2 разных пмг) + свои кастомные апгрейды. Так вот если я переконверчу апгрейды только, то проблем нет, а как только конверчу кабину и шасси - все апгрейды сбиваются.

А вот в DX11 вылезает такая ошибка:

Код:
00:00:17.803 : <ERROR> [dx11] Unable to map attribute (v.tex_coord_2)
00:00:17.803 : <ERROR> [dx11] Failed to create vertex input layout!
00:00:18.205 : <ERROR> [dx11] Unable to map attribute (v.tex_coord_2)
00:00:18.205 : <ERROR> [dx11] Failed to create vertex input layout!

Отредактировано axelrol (2019-05-04 18:03:40)

0

494

ZModeler3
Олег, где нужно поставить птичку, чтобы новые примитивы создавались с одним каналом, а не двумя?

0

495

Upd. Проблема решена - по оси Y стояло у модели 180 на даммисах. Видимо старая база была у меня.

0

496

Jazzycat написал(а):

ZModeler3
Олег, где нужно поставить птичку, чтобы новые примитивы создавались с одним каналом, а не двумя?

такой опции нет.

0

497

ZModeler3
Олег, появилась ещё одна небольшая проблемка. Имеется кастомный бампер для VNL, у которого я использую стандартные противотуманки от дефолта. По умолчанию когда импортируешь дефолтный бампер с габаритами, то заноза выставляет на втором канале (где лайтмаска) manual uv 2. Но игра использует лайтмаску основываясь на первом канале, поэтому приходится выставлять manual uv 1 (это можно проверить сразу в занозе - лаймаска в таком случае ложится правильно в отличие от той, когда делаешь импорт). Так вот раньше спокойно игра схватывала этот первый канал по лайтмаске, а сейчас когда начал делать реэкспорт с новым фильтром под 1.35, то она опять считывает её как из второго канала, хотя в занозе выставлено manual uv 1. Есть возможность проверить это?

0

498

axelrol, попробуй геометрию от материала с лайтмаской вытащить в отдельный объект.

еще .mat файл попробуй подменить (содержимое) на оригинал - ничего не меняется?

0

499

ZModeler3
Привет. Поменял большую часть железа в компьютере, как теперь подружить с этим новьем занозу правильно?

0

500

удалить старый ID в аккаунте, добавить новый. Остаток лицензии активировать для новой платформы.

0

501

Есть мод у меня у которого аним.пмд неизменно крашит после обновы. Переконвертировал - не помогает. И крашит с абсолютно чистым логом. Что за прикол такой, в каком краю решение искать, кто знает?

0

502

У кого есть проблемы с очисткой капель со стекол на версии 1 35? Реэкспорт с новым фильтром под 1.35. Ранее проблем с этим не было под более старыми версиями. Заноза пишет якобы проблемы с костями (при чем здесь кости не понятно...)

0

503

oq37 написал(а):

Есть мод у меня у которого аним.пмд неизменно крашит после обновы. Переконвертировал - не помогает. И крашит с абсолютно чистым логом. Что за прикол такой, в каком краю решение искать, кто знает?

попробуй под этот файл переэкспортировать еще и .pma файлы.

0

504

ZModeler3 написал(а):

попробуй под этот файл переэкспортировать еще и .pma файлы.

Я его грохнул и на основе нового, из 1.35. другой сделал и все заработало. Видать действительно с новой ПМА не контачил.

0

505

oq37 написал(а):

Я его грохнул и на основе нового, из 1.35. другой сделал и все заработало. Видать действительно с новой ПМА не контачил.

Олег, а если немного подробней, каким способом на его основе пмашку делал? Получается заново надо анимировать ее? Или пересохранял на пмашку которая с новой базой идет? Технологический процесс можешь описать?  :blush:

0

506

Stas556 написал(а):

с очисткой капель со стекол на версии 1 35?

На 1.34 у меня была проблема, но там просто перестали совпадать айди. Глянул в Занозе, правильный прописал и все заработало. Сейчас вроде все работает.

Stas556 написал(а):

каким способом на его основе пмашку делал?

Стас я не пмашку делал, там другое. Там мод, в котором в дефолтный аним. пмг добавлены луки свои и выведено в другую папку, но пмашки использовал дефолтные. После обновы начало вылетать. Вот я и взял новый дефолтный аним.пмг, добавил нужные луки и экспортнул. Этот вариант нормально совместился с новыми дефолтными пмашками.

0

507

просто для справки: единственное изменение в формате 1.35, которое я нашел, это привязка .pma к .pmg, чтоб посторонними .pma файлами игра не пыталась анимировать геометрию .pmg, которая этим анимациям может не соответствовать. экспорт в занозе под 1.35 эту привязку оставляет открытой (т.е. "любой .pma к любому .pmg" должен подходить в игре).

0

508

Длительность дворников и формат задержки
В модуле accessory_interior_data атрибут wiper_delay был удален. Вместо этого был добавлен новый атрибут wiper_duration_and_delay (массив float2). Каждый элемент содержит длину анимации (в секундах) и задержку между циклами анимации (в секундах) одного активного состояния.
Если wiper_duration_and_delay не указано правильно, по умолчанию используется один элемент float2 (2.0, 0.0), который в этом случае выступает в качестве одного активного состояния.

Отредактировано ШАМАН (2019-06-05 22:46:30)

0

509

ZModeler3

ATS 1.35

Прицеп scs_gooseneck

Missing shader adaptation for "eut2.retroreflective.tsnmapuv.piko.alldir" in material "439f0bf233853bbb".

0

510

ZModeler3 написал(а):

просто для справки: единственное изменение в формате 1.35, которое я нашел, это привязка .pma к .pmg, чтоб посторонними .pma файлами игра не пыталась анимировать геометрию .pmg, которая этим анимациям может не соответствовать. экспорт в занозе под 1.35 эту привязку оставляет открытой (т.е. "любой .pma к любому .pmg" должен подходить в игре).

Олег, я не понимаю это выражение - (т.е. "любой .pma к любому .pmg" должен подходить в игре). Каким образом это делается? Как я должен "привязать" pma к pmg? Они по сути и так должны быть привязаны... Или надо какую то галочку где то ставить?  :blush: Мне так и не удалось настроить стирание дождя в двух моих модах. Хотя с остальными модами проблем с этим нет, они и сделаны аналогично этим двум. Я предполагаю, что игра просто не видит думис дождя... Я уже все перепробовал, даже ставил дефолтные дворники вместо своих.

0


Вы здесь » PlayTruckSims: Грузовые симуляторы, Дальнобойщики, Euro Truck Simulator 2, American Truck Simulator » ZModeler » ZModeler3: вопросы, ответы, пожелания, помощь в освоении (часть 4/4)